WinWeb Is Phasing Out Support For Older Browsers.

browser_and_platform_compatibility_winweb

From August 1st, WinWeb will no longer support older browsers – those using IE7, Firefox (Mozilla) 3.5 and Apple’s Safari 3 or older will not be able to use the full functionality of the on-demand WinWeb micro business and small business software applications & business services. The decision was taken due to security and compatibility concerns.

The preferred browser is Mozilla’s Firefox 4.0 and later.

For users of Microsoft IE8 & IE9, with it’s limited HTML 5 compatibility we advise our clients to install a crome-frame plug-in (by Google) to enhance the HTML 5 compatibility and stability with our software apps.

We do fully support Google’s Crome internet browser.

Should any of our customers have any concerns or wish some support for upgrading to a safe and compatible internet browser, please contact our 24/7 Support Team.

comments powered by Disqus


Some WinWeb products, services, features may not be available in all territories, availability and features of products, services may change without notice. Compatible hardware and internet connection may be required for some WinWeb products and services.

Terms and Conditions apply, go to https://www.winweb.com/legal-information/ for more information. Prices exclude any form of applicable sales tax, i.e. GST and VAT - and special conditions may apply, i.e. per user per month, one off pricing, etc. All rights are reserved. E&OE.