mozilla

  • WinWeb Is Phasing Out Support For Older Browsers.

    2011-06-07

    From August 1st, WinWeb will no longer support older browsers – those using IE7, Firefox (Mozilla) 3.5 and Apple’s Safari 3 or older will not be able to use the full functionality of the on-demand WinWeb micro business and small business software applications & business services. The decision was taken due to security and compatibility [...]

    Read more